phpMyAdminで「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました」が出る時の対処法

phpMyAdminで「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました」が出る時の対処法

phpMyAdminで「設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました」が出る時の対処法
  • シェアしてね♪
  • このエントリーをはてなブックマークに追加

  • 広告主様募集中
    ワンコインで広告掲載してみませんか?
  • このエントリーをはてなブックマークに追加

XAMPPのphpMyAdminをアップデートしたところ、管理画面にアクセスする度に、以下のようなエラーメッセージが表示されるようになりました。

設定ファイルに、暗号化 (blowfish_secret) 用の非公開パスフレーズの設定を必要とするようになりました。

これを解消するためには、phpMyAdminのディレクトリ内にあるconfig.inc.phpを編集する必要があります。

スポンサードリンク

blowfish_secretのエラーメッセージを解消する

phpMyAdminディレクトリにconfig.inc.phpがあれば、それをテキストエディタで開きます。なければ、config.sample.inc.phpをコピーして、config.inc.phpにリネームしてください。

config.inc.phpを開くと、以下のような記述があります。

config.inc.php
$cfg['blowfish_secret'] = '';

ここの適当な値を入れます。値は何でもOKです。

config.inc.php
$cfg['blowfish_secret'] = 'key';

再度phpMyAdminにアクセスすると、エラーメッセージは表示されなくなっています。

あとがき

非常に簡単に対処できますね。もし同じメッセージが表示されていたら、上記手順で対処してみてください。

 

この記事が気に入ったら
いいね!してね♪

Twitter で
スポンサードリンク

関連記事

コメントを残す

メールアドレスが公開されることはありません。