テーマやプラグインがPHPの各バージョンに対応しているか確認できるWordPressプラグイン「PHP Compatibility Checker」

テーマやプラグインがPHPの各バージョンに対応しているか確認できるWordPressプラグイン「PHP Compatibility Checker」

テーマやプラグインがPHPの各バージョンに対応しているか確認できるWordPressプラグイン「PHP Compatibility Checker」
  • シェアしてね♪
  • このエントリーをはてなブックマークに追加

  • sNews.jp さがみはらのニュースがいっぱい!
  • このエントリーをはてなブックマークに追加

PHP Compatibility Checkerは、インストールしているテーマやプラグインがPHP7等に対応しているか確認できるWordPressプラグインです。

PHP7はパフォーマンスが従来のPHPよりも改善されているので、PHP7が使えるサーバーではPHP7に切り替えたいと思っている方も多いと思います。ですが、利用しているテーマやプラグインがPHP7に対応していないこともあり、対応していないとエラーが発生してサイトが表示できなくなる場合もあります。

PHP Compatibility Checkerを使えば、そんなことにならないように、PHPの各バージョンに対応しているかどうかを事前にチェックすることができます。

スポンサードリンク

PHP Compatibility Checkerのインストール

インストール手順は以下の通りです。

  1. PHP Compatibility Checkerをダウンロードします。
  2. ダウンロードしたファイルを展開し wp-content/plugins にアップロードします。
  3. 管理画面の[プラグイン]ページで、PHP Compatibility Checkerを有効化します。

PHP Compatibility Checkerの使い方

プラグインを有効化して、[ツール] – [PHP Compatibility]にアクセスします。

「PHP Version」から確認したいバージョンを選択し、「Plugin / Theme Status」ですべてのテーマ/プラグインをチェックするか、有効化しているテーマ/プラグインのみをチェックするか選択します。

PHP Compatibility Checkerの使い方

[Scan site]をクリックすると、スキャンが開始され、結果が表示されます。

スキャン結果

[toggle details]をクリックすれば詳細が表示され、[Download Report]をクリックすればレポートをダウンロードすることもできます。

あとがき

PHPのバージョンを切り替えた後で対応していないことがわかった場合、またバージョンを元に戻さなければいけません。そうならないように、PHPのバージョンを切り替える際は、事前にPHP Compatibility Checkerでチェックすることをおすすめします。

この記事が気に入ったら
いいね!してね♪

Twitter で
スポンサードリンク

関連記事

コメントを残す

メールアドレスが公開されることはありません。